*Important* system is down for maintenance
Incident Report for Proposify
Resolved
The site is back up and running!
Posted Jul 29, 2015 - 01:16 ADT
Identified
We are down for some urgent maintenance starting at 12 am Atlantic time for approximately 45 minutes. If you have any questions or concerns, please email support@proposify.biz or subscribe for updates.
Posted Jul 29, 2015 - 00:05 ADT